Kamus PCQ pada queue type

PCQ pada queue type adalah salah satu feature dari MikroTik untuk membantu memanage traffic rate
dan traffic packet, disini saya mencoba menuliskan catatan kecil mengenai perhitungan
classifier dst.address dan dst.port atau yg lebih di kenal memanage traffic download.

Dimana sebaiknya PCQ itu ditempatkan?
pcq dapat ditempatkan pada parent maupun child/klien, namun dalam kasus tutorial kali ini
pcq sebaiknya ditempatkan pada parent atau kelompok packet

contoh gambar pada kotak merah


cara menempatkannya

kenapa mesti ditempatkan pada parent atau kelompok packet?
karena pada tempat tersebut nanti yg akan di lalui semua traffic dari internet ke klien
jadi kalau ditempatkan pada klien otomatis yang akan tershaping hanyalah di klien tersebut.

Cara membuat PCQ

setelah itu akan muncul seperti ini

untuk type name silahkan isi sesuai selera

PCQ default

artinya untuk settingan di atas tidak mempengaruhi traffic apapun

PCQ Classifier dst.port atau dst.port dan dst.address dengan rate 64k

atau

artinya untuk classfier dst.port atau dst.port dan dst.address dengan rate 64k
klien-001 download dari suatu server mendapatkan rate bw 64k dalam satu sub stream/koneksi
jika klien-001 download menggunakan download manager dengan 8 koneksi/pararel
maka klien-001 tersebut akan mendapatkan rate 64k x 8 = 512k sampai batas max-limit queue
Begitu pula rule di atas berlaku untuk klien-002 klien-003 dan seterusnya…

PCQ classifier dst.address

artinya untuk classifier dst.address dengan rate 64k
klien-001 download akan mendapatkan rate bw 64k dan apa bila klien-001 download
menggunakan download manager dengan 8 koneksi/pararel maka klien00-1 tersebut
hanya akan mendapatkan bw rate 64k saja. karena pcq telah menshaping dengan
classifier destination address (dst.address) ke klien.
Rule di atas berlaku untuk klien-002 klien-003 danseterusnya…

Semoga catatan kecil ini bermanfaat bagi anda.

6 thoughts on “Kamus PCQ pada queue type

  1. mas , blh tnya ya .itu untuk aturan manglenya : buat mangle donwload & upload kyk gmn? masing-masing klien di buatkan aturan mangle sendiri, dibuatkan connection+packet’nya per ip (klien) atau cukup networknya aja(ex : src-address=192.167.0.0/27 )

    tolong d koreksi ya mas, kalo ada yang salah .soalnya msh belajar .makasih byk.
    atau masing-masing kyk gni :

    —————
    Mangle Donwload
    —————
    /ip firewall mangle add chain=forward src-address=192.167.0.1 action=mark-connection new-connection-mark=klien-001_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.2 action=mark-connection new-connection-mark=klien-002_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.3 action=mark-connection new-connection-mark=klien-003_conn passthrough=yes
    ——-
    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-001_conn action=mark-packet new-packet-mark=klien-001-up passthrough=no

    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-002_conn action=mark-packet new-packet-mark=klien-002-up passthrough=no

    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-003_conn action=mark-packet new-packet-mark=klien-003_up passthrough=no

    dst …..
    ————

    ————-
    Mangle Upload
    ————-
    /ip firewall mangle add chain=forward src-address=192.167.0.1 action=mark-connection new-connection-mark=klien-001_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.2 action=mark-connection new-connection-mark=klien-002_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.3 action=mark-connection new-connection-mark=klien-003_conn passthrough=yes
    ——-
    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-001_conn action=mark-packet new-packet-mark=klien-001-dn passthrough=no

    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-002_conn action=mark-packet new-packet-mark=klien-002-dn passthrough=no

    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-003_conn action=mark-packet new-packet-mark=klien-003-dn passthrough=no

    dst …..
    ——-

    msh bingung ,untuk chain=foward dan prerouting penerapan yang pas tu gmn c mas ?? makasih .

  2. mas , blh tnya ya .itu untuk aturan manglenya : buat mangle donwload & upload kyk gmn? masing-masing klien di buatkan aturan mangle sendiri, dibuatkan connection+packet’nya per ip (klien) atau cukup networknya aja(ex : src-address=192.167.0.0/27 )

    tolong d koreksi ya mas, kalo ada yang salah .soalnya msh belajar .makasih byk.
    atau masing-masing kyk gni :

    —————
    Mangle Donwload
    —————
    /ip firewall mangle add chain=forward src-address=192.167.0.1 action=mark-connection new-connection-mark=klien-001_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.2 action=mark-connection new-connection-mark=klien-002_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.3 action=mark-connection new-connection-mark=klien-003_conn passthrough=yes
    ——-
    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-001_conn action=mark-packet new-packet-mark=klien-001-up passthrough=no

    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-002_conn action=mark-packet new-packet-mark=klien-002-up passthrough=no

    /ip firewall mangle add chain=forward in-interface=local connection-mark=klien-003_conn action=mark-packet new-packet-mark=klien-003_up passthrough=no

    dst …..
    ————

    ————-
    Mangle Upload
    ————-
    /ip firewall mangle add chain=forward src-address=192.167.0.1 action=mark-connection new-connection-mark=klien-001_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.2 action=mark-connection new-connection-mark=klien-002_conn passthrough=yes

    /ip firewall mangle add chain=forward src-address=192.167.0.3 action=mark-connection new-connection-mark=klien-003_conn passthrough=yes
    ——-
    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-001_conn action=mark-packet new-packet-mark=klien-001-dn passthrough=no

    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-002_conn action=mark-packet new-packet-mark=klien-002-dn passthrough=no

    /ip firewall mangle add chain=forward in-interface=public connection-mark=klien-003_conn action=mark-packet new-packet-mark=klien-003-dn passthrough=no

    dst …..
    ——-

    msh bingung ,untuk chain=foward dan prerouting penerapan yang pas tu gmn ya mas ?? makasih .

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s